Mes premières procédures en Logo avec Papy Logo par Pierre-Louis U.

 

15:09 17/05/00

POUR CARRE :TAILLE ;;attention : carré peut être une PRIMITIVE = dans les bons Logo(s)
;;ce sera la procédure pour le carré d'un nombre, pour les "pas bons" Logo(s), ce sera une figure préfabriquée.
REPETE 4 [ AV :TAILLE TD 90 ]
FIN

POUR CARREPP :TAILLE ;;carré(s) de + en + petit(s) (décrémentation)
SI :TAILLE < 5 [STOP]
CARRE :TAILLE
FCC CC + 1
CARREPP :TAILLE - 5
FIN

POUR PENTA :TAILLE ;;pentagone
REPETE 5 [ AV :TAILLE TD 360 / 5 ]
FIN

POUR PENTAPP :TAILLE ;;décrémentation du (des) pentagone(s)
SI :TAILLE < 5 [STOP]
PENTA :TAILLE
FCC CC + 1
PENTAPP :TAILLE - 5
FIN

POUR ROSACAR :FOIS :TAILLE
REPETE :FOIS [CARRE :TAILLE TD 360 / :FOIS FCC CC + 1]
FIN

POUR ROSPENTAPP :FOIS :TAILLE ;;un exemple (sur tant ... ) en image (51 Ko)
REPETE :FOIS [PENTAPP :TAILLE TD 360 / :FOIS FCC CC + 1]
FIN


15:04 07/06/00

De P_Logo au JFLogo :

pour care00 :t ;;voir le attention en haut de cette page ...
repete 4 [av :t td 90]
fin

pour rosacar :t :x ;;moi (P.L.), j'aurais écrit = pour rosacar :x :t ... Mais bon ...
;;Un exemple (sur 360 * :x * :t ...) de
réalisation (25 Ko)
repete :x [care00 :t td 360 / :x fcc hasard 256]
fin

 

 Revenir au CONTENU de P.L.