Les Outils TRACER, DIRIGER, DESSINER


Voir le "Livre du Maître", Dessins et Images d'enfants.

Ces procédures et programmes sont en P_Logo version DOS pour Compatibles "PC" ; si vous insistez auprès de Jean-François Lucas et de moi-même, DESSINER.LOG pourrait, un jour, être un élément du JFLogo pour Windows 95 et + (...) Un excellent exercice consisterait
à réaliser l'adaptation, le portage, vous même selon votre machine et votre version de Logo...
:-)
Ceci est devenu inutil depuis que j'ai mis deux de ces outils en téléchargement avec le langage Logo. Voir en fin de page.


Ces 3 outils (2 si l'on a un bon Logo permettant d'utiliser tout le Pavé Numérique du clavier et, donc, de réunir Diriger et Tracer en un seul programme comme je l'avais conçu avec la version pour ATARI de P_Logo), ont en commun d'utiliser le "Quadrillage" (papier millimétré). Voici donc les procédures construisant ce dernier ; elles sont à adapter selon la taille et la résolution de votre écran.
Ici, comme partout en ces Pages comprenant des Programmes, certaines Procédures sont commentées afin d'aider à comprendre la démarche... Mais rien n'est donné à 100% : mon propos est, aussi, d'ouvrir à la réflexion et non de se contenter de Copier/Coller... ;-)

POUR DEB ;;tout a un début. Là il se trouve en bas à gauche de l'écran
LC TG 90 AV 310 TD 90 RE 180 BC
FIN

POUR ESP ;;espace (voir aussi "Logo-Lego")
LC TD 90 AV 10 TG 90 BC
FIN

POUR LIV ;;ligne verticale
AV 360 RE 360
FIN

POUR LIH ;;ligne horizontale (si si !)
AV 620 RE 620
FIN

POUR QUAD ;;Quadrillage, la procédure principale à lancer...
;;Et : ces 5 procédures sont bien à mettre dans chacun des 2 ou 3 outils. On est d'accord ?!...
;;Retour fin Tracer - Retour fin Diriger - Retour fin Dessiner
VE CT DEB
REPETE 62 [LIV ESP] LIV TG 90
REPETE 36 [LIH ESP] LIH ;;and why not repete 63 and repete 37, hue, hue ?!...
LC ORIGINE BC MT
FIN



Commençons avec TRACER qui est, pour moi, le premier utilisé, écrit à la demande de maîtresses de classes spécialisées (enfants ne sachant pas forcément lire). Cet outil est à la limite de l'anti-Logo ; en effet : la Tortue se déplace ici vers le "haut", le "bas", la droite, la gauche DE l'écran par l'utilisation des 4 flèches correspondantes (entre le clavier lettres et le pavé numérique). Ce qui est une hérésie totale ; donc, cet outil n'a rien à voir avec la Restructuration de l'Enfant dans l'Espace. Cet outil existe pour d'autres raisons à imaginer par les pédagogues. Même remarque au sujet de DIRIGER.


POUR MOTEUR ;;pas de hasard dans le choix du nom de cette procédure...
;;On ne peut utiliser que ces 4 flèches, donc, car ce P_Logo a un problème de Pile...

DONNE "Z LISCAR
SI :Z = 18432 [FCAP 0 AV 10]
SI :Z = 20480 [FCAP 180 AV 10]
SI :Z = 19712 [FCAP 90 AV 10]
SI :Z = 19200 [FCAP 270 AV 10]
MOTEUR
FIN

POUR DOC ;;"l'Aide en ligne" de tout bon outil informatique... Voir PUB
ME 5 VT FCT 7
EC [Utiliser les 4 flèches : Haut, Bas, Droite, Gauche]
EC [^C pour Tout Arrêter ......... Penser … ^C QUADEMO] ;;donc pas de Touche dédiée à l'arrêt du Programme
;;puisque, dans celui-ci, on ne peut en utiliser une seule supplémentaire {^ = Ctrl (Contrôle)}

EC [Si perdu ? alors VE TRACER] ;;pense-bête pour maître, animateur ou enfant 'lisant'
EC [Pas d'ORIGINE...] ;;eh oui, hélas...
FIN

POUR PUB ;;un outil informatique a toujours son "A-propos". Ceci donne l'occasion d'en parler (!)
ME 25 VT
FTCAR [2 2] FCT 1
FCURS [15 4] EC [TRACER] FTCAR [1 1]
FCT 4
FCURS [8 7] EC [une version simplifiée de]
FTCAR [2 2] FCT 9
FCURS [13 9] EC [DESSINER] FTCAR [1 1]
FCT 10
FCURS [6 13] EC [by Olivier Schmidt-Chevalier]
FCT 5
FCURS [9 17] EC [V 2.1 with P_LOGO V 3.02d]
FCT 12
FCURS [7 21] EC [Appuie sur C pour Commencer]
FIN

POUR TRACER
PUB
DONNE "Z LISCAR
SI :Z = "C [DOC FCC 15 QUAD FCC 12 MOTEUR] [TRACER] ;;on ne va pas se laisser faire par les "fortes têtes"...
FIN

POUR QUADEMO ;;le Quadrillage tout en rouge, but de l'exercice demandé.
;;Vous pouvez en imaginer bien d'autres.

VE CT FCC 12 DEB
REPETE 62 [LIV ESP] LIV TG 90 ;;au fait : vous avez trouvez why not 63*37 ?...
REPETE 36 [LIH ESP] LIH
LC ORIGINE BC MT
FIN

TRACER ;;démarrage automatique en sortant de l'Editeur (^Q) {Ne pas oublier}



Passons à DIRIGER.LOG. L'original, pour ATARI, utilisait les touches du Pavé Numérique (1, 2, 3, 4, 6, 7, 8, 9 pour les huit directions : 2 verticales, 2 horizontales, 4 diagonales et le 5 pour le retour au centre ; l'Origine de Logo. A propos de ces huit directions, l'on peut aussi parler des Points Cardinaux ; ouvrir aussi sur la géographie... [C'est un métier ! ;-)]


POUR DESS2 ;;le Moteur de ce Programme. Choix des lettres selon leurs dispositions sur un clavier français.
DONNE "Z LISCAR
SI EGAL? :Z "Y [FCAP 0 AV 10] ;;vers haut écran
SI EGAL? :Z "B [FCAP 180 AV 10] ;;vers bas écran
SI EGAL? :Z "F [FCAP 270 AV 10] ;;vers gauche écran
SI EGAL? :Z "J [FCAP 90 AV 10] ;;vers droite écran
SI EGAL? :Z "T [FCAP 315 AV 14.2] ;;10 * 1.41 règle mathématique - haut-gauche
SI EGAL? :Z "U [FCAP 45 AV 14.2] ;;10 * 1.42 pour ce Logo ou écran - haut-droite
SI EGAL? :Z "V [FCAP 225 AV 14.2] ;;bas-gauche
SI EGAL? :Z "N [FCAP 135 AV 14.2] ;;bas-droite
SI EGAL? :Z "G [LC ORIGINE BC] ;;le centre (.)
SI EGAL? :Z "E [VE QUAD] ;;tout effacer et remettre le Quadrillage
SI EGAL? :Z "0 [FCC 0] ;;avec un choix de 10 couleurs. Merci Papy Logo !
SI EGAL? :Z "1 [FCC 1]
SI EGAL? :Z "2 [FCC 13]
SI EGAL? :Z "3 [FCC 6]
SI EGAL? :Z "4 [FCC 8]
SI EGAL? :Z "5 [FCC 9]
SI EGAL? :Z "6 [FCC 10]
SI EGAL? :Z "7 [FCC 12]
SI EGAL? :Z "8 [FCC 14]
SI EGAL? :Z "9 [FCC 15]
SI EGAL? :Z "S [STOP] ;;on pense même à arrêter le programme ! C'est "propre" !
DESS2 ;;lui aussi il boucle ainsi que le faisait aussi le Moteur de Tracer...
FIN

POUR DIRIGER
ME 6 VT QUAD FCT 10
EC [********************* DIRIGER v 1.2 ===== Olivier S.C. *********************] FCT 15
;;le "A_propos" et "l'Aide en ligne"
EC [***** Y = haut, B = bas, J = droite, F = gauche, de l'écran ****************]
EC [***** T = haut-gauche, U = haut-droite, de l'écran - E = tout effacer ******]
EC [***** V = bas-gauche, N = bas-droite, G = centre de l'écran - S = stop *****]
EC [***** Les couleurs = 0, 1, 2, 3, 4, 5, 6, 7, 8, 9*Rameneimage "Demdirig.PCX*] ;;mon pense-bête :
;;un des nombreux exercices possible... Attention : prévenir les enfants des "dangers"
;;si la Tortue sort de l'écran, il faut alors tout recommencer.
;;Pour les + petits, mettre un FEN plutôt qu'un ENR ? Idem pour TRACER & DESSINER.

DESS2
FIN

DIRIGER ;;démarrage automatique en sortant de l'Editeur {Ne pas oublier}



And now, Mesdames und Messieurs : DESSINER.LOG, l'original, le "papa" des deux autres outils. Exercice classique des programmeurs Logo, l'original remonte aux débuts même de Logo. On peut imaginer de l'enrichir en prévoyant sauvegardes et autres possibilités offertes par le langage lui-même.
Celui-ci est, enfin, réellement du Logo où l'enfant est la Tortue et dont la main droite ne désignera pas le même mur selon qu'il est face au Nord ou face au Sud (ça "marche" aussi avec l'East et l'West !). La Tortue ne va plus à droite ou à gauche ; elle doit, auparavant, se tourner vers... Elément primordial que même peut d'adultes ne comprend : on ne va pas à gauche ; on tourne à gauche puis on avance...


POUR DESS ;;le Moteur (j'insiste... ;-) )
DONNE "Z LISCAR
SI EGAL? :Z "A [AV 10] ;;10 pas, soit, aussi la dimension d'un carreau du Quadrillage, ya ?
SI EGAL? :Z "R [RE 10]
SI EGAL? :Z "D [TD 10] ;;10 pas, then why not 10° ? Système décimal français, Sir !
SI EGAL? :Z "G [TG 10]
SI EGAL? :Z "V [VE]
SI EGAL? :Z "L [LC]
SI EGAL? :Z "B [BC]
SI EGAL? :Z "C [CT]
SI EGAL? :Z "M [MT]
SI EGAL? :Z "O [LC ORIGINE BC]
SI EGAL? :Z "P [REMPLIS] ;;P de peindre as le pot de couleur de Paint. Remplir est une démarche pédagogique :
;;1) dessiner une forme fermée (que la couleur ne déborde pas), 2) mettre la Tortue à l'intérieure sans faire de trait
;;et Elle ne doit toucher aucun bord du dessin, 3) choisir une couleur, 4) touche P pour le Remplis de P_Logo...
;;changer de couleurs afin de voir la Tortue, la mettre ailleurs, baisser le crayon et recommencer !...

SI EGAL? :Z "0 [FCC 0] ;;un choix de dix couleurs
SI EGAL? :Z "1 [FCC 1]
SI EGAL? :Z "2 [FCC 13]
SI EGAL? :Z "3 [FCC 6]
SI EGAL? :Z "4 [FCC 8]
SI EGAL? :Z "5 [FCC 9]
SI EGAL? :Z "6 [FCC 10]
SI EGAL? :Z "7 [FCC 12]
SI EGAL? :Z "8 [FCC 14]
SI EGAL? :Z "9 [FCC 15]
SI EGAL? :Z "H [AIDO] ;;afficher l'écran Aide (H pour Help, le A d'Aide étant déjà pris = d'autres questions ?)
SI EGAL? :Z "S [STOP] ;;toujours songer à pouvoir arrêter proprement. Attention : sur un clavier français, le S
;;est juste à gauche du D (de Tourne_Droite), alors, les doigts "boudinés...

SI EGAL? :Z "W [DESSINER] ;;passer de l'écran Aide à celui de travail
SI EGAL? :Z "Q [QUAD] ;;si on veut le Quadrillage
SI EGAL? :Z "X [DEMO] ;;pour ceux qui se demandent ce que l'on peut faire avec cette outils
SI EGAL? :Z "Y [QDEM] ;;et, entre autres exemples...
DESS
FIN

POUR DESSINER
ME 6 VT
EC [Appuie sur H pour obtenir de l'aide] ;;A étant pris, H pour Help ! {Je vous remercie !}
;; Il n'est pas interdit de le dire aux enfants, c'est même conseillé...

EC [ATTENTION: ton dessin sera effacé !...]
EC " EC [X for DEMO, Y for QDEM ! Stop & RAMENEIMAGE "MAISDESS.PCX] ;;faut pas rêver : faites
;;vos propres chef d'oeuvres !...

DESS
FIN

POUR AIDO ;;"l'A-propos + "l'Aide en ligne", le "mode d'emploi", la "doc.", un "lis_moi_first"
ME 25 VT FCT 10
EC [== DESSINER v 2.1 = Olivier S.C. ==]
EC [-----------------------------------] EC "
FCT 7
EC [Appuie sur A pour Avancer de 10 pas]
EC [Appuie sur R pour Reculer de 10 pas]
EC [Appuie sur D pour Tourne_Droite de 10°]
EC [Appuie sur G pour Tourne_Gauche de 10°]
EC [Appuie sur V pour Vide Ecran [Effacer]] EC "
EC [Appuie sur L pour Lève Crayon]
EC [Appuie sur B pour Baisse Crayon]
EC [Appuie sur C pour Cache Tortue]
EC [Appuie sur M pour Montre Tortue]
EC [Appuie sur O pour Origine]
EC [Appuie sur P pour Peindre] EC "
EC [Si tu veux des couleurs, appuie sur:]
EC [0, 1, 2, 3, 4, 5, 6, 7, 8 ou 9 ...]
EC [... Surprise !...] EC "
EC [\\\\\ Q = écran quadrillé - S = stop] EC "
EC [Appuie sur W pour revenir … DESSINER.]
FIN

POUR DEMO ;;démo écrite en Logo mais chaque exemple a été réalisé avec Dessiner avant, en test (la voir)
VE CT REPETE 36 [AV 10 TD 10]
LC TD 90 AV 10 BC MT
AV 10 FCC 1 AV 10 FCC 4 AV 10 FCC 5
AV 10 FCC 8 AV 10 FCC 9 AV 10 FCC 10 AV 10
FCC 12 AV 10 FCC 14 AV 10 LC ORIGINE
TG 90 AV 130 TD 90 RE 60 BC FCC 7
REPETE 4 [AV 25 TD 90] AV 25 TD 30 FCC 13
REPETE 3 [AV 25 TD 120] TG 30
LC AV 50 BC FCC 1 AV 40 RE 40 TD 90 AV 20
LC AV 10 TG 90 FCC 4 BC
REPETE 2 [AV 40 TD 90 AV 20 TD 90]
LC TD 90 AV 30 BC FCC 1 AV 20 TG 90
AV 10 TG 90 AV 10 RE 20 AV 10 TD 90
RE 10 TG 90 AV 20 TD 90 AV 40 TD 90 AV 20
LC AV 20 BC FCC 4
REPETE 2 [AV 20 TD 90 AV 40 TD 90]
LC ORIGINE TG 90 AV 86 TD 90 BC FCC 5
REPETE 3 [RE 10 LC RE 10 BC]
TD 90 FCC 10 REPETE 7 [AV 20 LC AV 10 BC]
LC ORIGINE TG 90 AV 45 TD 90 RE 20 BC
FCC 9 AV 5 TD 90 AV 10 TD 90 AV 15 TD 90 AV 20
TD 90 AV 25 TD 90 AV 30 TD 90 AV 35
LC AV 50 BC FCC 15 REPETE 5 [AV 60 TD 72]
LC TD 30 AV 35 BC FCC 14 REMPLIS FCC 1 FCAP 0
FIN

POUR QDEM ;;idem que Démo. Réalisation plus aisée à faire avec Tracer ?... (vue okay ?!). Enfin, par jeu (sadique),
;;montrer comment, sur le Quadrillage de Dessiner il est facile et rapide de réaliser l'exercice proposé avec Tracer !...
;;Et oui, au fait, comment ?!...

VE QUAD LC AV 10 BC FCC 12
REPETE 4 [AV 40 TD 90 AV 20 TD 90 AV 40 TG 90]
LC AV 10 TG 90 AV 10 TD 90 BC
REPETE 4 [AV 40 TD 90 AV 40 TD 90 AV 40 TG 90] CT
FIN

DESSINER ;;démarrage automatique en sortant de l'Editeur {Ne pas oublier ; bâillement de lassitude...}



 Ce que l'on voit à l'écran ...

 RETOUR


 

 Vers l'espace de téléchargement

Vers les versions récentes de ces outils.


 Hit-Parade