Anneaux civilisationnels

 

Vus par Stéphane H. - Baby Logo

 

Cliquez sur Précédente afin de revenir ici si vous allez visiter les liens proposés.


Stéphane H., Baby Logo, est de plus en plus mentionné en ces pages ; du CMIRH à ses travaux, ceux de ses enfants et de ses élèves. Stéphane a utilisé la même version de P_Logo que moi pour réaliser ses propres visions d'artiste mordu de mathématique. Je ne sais dans quel ordre il a concocté ses différentes procédures ; je les présente donc un peu au hasard, en terminant par le programme aboutissant sur la plus jolie réalisation.

Un travail superbe !

POUR C ; colonies
E
P
FIN

POUR E ; étoile
CT FCC 12
REPETE 360[AV HASARD 40 RE DISTANCE [0 0] TD 1]
FCC 14 ;;
en plus, Baby Logo vous offre une Primitive que Papy Logo n'a jamais utilisé.
;;Merci Stéphane !
REPETE 360[AV HASARD 30 RE DISTANCE [0 0] TD 1]
FIN

POUR P ; planètes
REPETE 12[ FCC HASARD 15 LC AV 130 BC REPETE 360[AV 10 RE 10 TD 1] S LC RE 130 TD 30]
FIN

POUR S ;;soleil, je pense...
REPETE 12[ FCC HASARD 15 LC AV 27 BC REPETE 360[AV 4 RE 4 TD 1] V LC RE 27 TD 30]
FIN

POUR V ;;as visiteurs ?!...
REPETE 12[LC AV 7 BC FCC 11 AV 1 LC RE 8 TD 30]
FIN

POUR C ; colonies
E
P
FIN

POUR E ; étoile
CT FCC 12
REPETE 360[AV HASARD 40 RE DISTANCE [0 0] TD 1]
FCC 14
REPETE 360[AV HASARD 30 RE DISTANCE [0 0] TD 1]
FIN

POUR P ; planètes
REPETE 12[ FCC HASARD 16 LC AV 145 BC REPETE 360[AV 10 RE 10 TD 1] S LC RE 145 TD 30]
FIN

POUR S ; satellites
REPETE 12[ FCC HASARD 16 LC AV 30 BC REPETE 360[AV 4 RE 4 TD 1] V LC RE 30 TD 30]
FIN

POUR V ; voyager ;;oups, pardon, autant pour moi ! Voir plus haut...
REPETE 12[ FCC HASARD 16 LC AV 10 BC REPETE 360[AV 2 RE 2 TD 1] LC RE 10 TD 30]
FIN ;;
entre les 2, une planète noire a disparue. Comment ?
;;Eh oui, ce n'était ni un trou noir, ni une étoile noir : pas les mêmes filmes...

POUR S ; startreck ;;faut tout leur dire !...
A
B
FIN

POUR AZAR ;;ce hasard était devenu une nécessité. Je vous en prie : restez couvert !
DONNE "D HASARD 16
SI :D = 0 [AZAR]
SI :D = 8 [AZAR]
FCC :D
FIN

POUR A ; planète en coupe ;;rien à voir avec Massacre à la tronçonneuse... ;-)
CT FCC 12
REPETE 360[AV 40 RE 40 TD 1]
FCC 14
REPETE 360[AV 32 RE 32 TD 1]
FCC 10
REPETE 360[AV HASARD 12 RE DISTANCE [0 0] TD 1]
FIN

POUR B ; feux de Bengale
REPETE 12[ LC AV 60 BC REPETE 360[AZAR AV 10 RE 10 TD 1] C LC RE 60 TD 30]
FIN

POUR C ; trois colonies
FCAP CAP - 30 REPETE 3[AZAR LC AV 30 BC REPETE 360[AV 4 RE 4 TD 1] V LC RE 30 TD 30] TG 60
FIN

POUR V ; d'autres prolongements
FCAP CAP - 30 REPETE 3[AZAR LC AV 20 BC REPETE 360[AV 1 RE 1 TD 1] Q LC RE 20 TD 30] TG 60
FIN

POUR Q ;;Q, vous savez ? L'emm...... dans Star Trek Nouvelle Génération. Il est fort BL !
FCAP CAP - 30 REPETE 3[AZAR LC AV 5 BC AV 1 LC RE 6 TD 30] TG 60
FIN

POUR S ; startreck
A
B
FIN

POUR AZAR
DONNE "D HASARD 16
SI :D = 0 [AZAR]
SI :D = 8 [AZAR]
FCC :D
FIN

POUR A ; planète en coupe
CT FCC 12
REPETE 360[AV 40 RE 40 TD 1]
FCC 14
REPETE 360[AV 32 RE 32 TD 1]
FCC 10
REPETE 360[AV HASARD 12 RE DISTANCE [0 0] TD 1]
FIN

POUR B ; feux de Bengale
REPETE 12[ LC AV 60 BC REPETE 360[AZAR AV 10 RE 10 TD 1] C LC RE 60 TD 30]
FIN

POUR C ; deux colonies
FCAP CAP - 20 REPETE 2[AZAR LC AV 30 BC REPETE 360[AV 4 RE 4 TD 1] V LC RE 30 TD 40] TG 60
FIN

POUR V ; d'autres prolongements
FCAP CAP - 25 REPETE 2[AZAR LC AV 12 BC REPETE 360[AV 1 RE 1 TD 1] Q LC RE 12 TD 50] TG 75
FIN

POUR Q ; conQuête ;;oh l'autre, l'humour de 22 heures 25. Too bad for Q, cf. + haut...
FCAP CAP - 20 REPETE 2[AZAR LC AV 8 BC AV 1 LC RE 9 TD 40] TG 60
FIN

POUR C ; colonies ;;la version que je préfère !
E
P
FIN

POUR E ; étoile
CT FCC 12
REPETE 360[AV HASARD 40 RE DISTANCE [0 0] TD 1]
FCC 14
REPETE 360[AV HASARD 30 RE DISTANCE [0 0] TD 1]
FIN

POUR P ; planètes
REPETE 12[ FCC HASARD 16 LC AV 145 BC REPETE 360[AV 8 RE 8 TD 1] S LC RE 145 TD 30]
FIN

POUR S ; satellites
REPETE 12[ FCC HASARD 16 LC AV 28 BC REPETE 360[AV 3 RE 3 TD 1] V LC RE 28 TD 30]
FIN

POUR V ; voyager
REPETE 12[ FCC HASARD 16 LC AV 7 BC REPETE 360[AV .5 RE .5 TD 1] LC RE 7 TD 30]
FIN



Pris dans le feu de l'action, l'imagination débordante de Baby Logo amena le ci-devant Stéphane H. à réaliser un "petit film" relatant le côté 'exponentiel' de ces anneaux civilisationnels ; pour peu que le Grand Zardoz - Sorcier de son état -, prête vie aux briques basiques des dites civilisations. Vous, lui et moi ; en quelques sortes !...
Ce faisant, BL est allé au-delà du programme que je n'ai jamais ré-écrit et dont je parle à cette page du
Passeport Logo.
Que dire d'autre ? Que, comme tout premier film, celui-ci comporte ses longueurs ? Eh bien non ! Je voudrais vous y voir ! Vos propositions de scénarios sont les bienvenues !

POUR C ; couronne
LC FPOS [-57 0] BC
REPETE 360 [AV 15 RE 30 AV 16 TD 1 AZAR ]
FIN

POUR AZAR
DONNE "D HASARD 16
SI :D = 0 [AZAR]
SI :D = 8 [AZAR]
FCC :D
FIN

POUR D ; disque central
CT LC ORIGINE BC
FCC 10 REPETE 360 [AV 40 RE 40 TG 1]
FCC 14 REPETE 360 [AV HASARD 30 RE DISTANCE [0 0] TG 1]
FIN

POUR E ; exploration
MT LC FCC 6
REPETE 180[AV 1 TD 1 ATTENDS 1]
FIN

POUR N1 ; nouveau monde
CT BC REPETE 360[AZAR AV 12 RE 12 TG 1 ATTENDS .1]
REPETE 10 [REPETE 360[AZAR AV 12 RE 12 TG 1] ]
FIN

POUR N2 ; nouveau monde
CT BC FCC 3 REPETE 360[AV 14 RE 14 TG 1 ATTENDS .2]
FCC 4 REPETE 360[AV 1 + HASARD 9 RE DISTANCE [36 -108] TD 1 ATTENDS .2]
FCC 1 REPETE 360[AV 1 + HASARD 6 RE DISTANCE [36 -108] TG 1 ATTENDS .2]
FIN

POUR N3 ; nouveau monde
CT BC REPETE 3[FCC CC + 4 REPETE 120[ AV 12 RE 12 TG 1 ATTENDS .2]]
FIN

POUR N4 ; nouveau monde
CT BC REPETE 72[ FCC CC + 1 REPETE 5[AV 12 RE 12 TG 1 ATTENDS .2]]
FIN

POUR N5 ; nouveau monde
CT BC REPETE 360[ FCC CC + 2 AV 12 RE 12 TD 1 ATTENDS .2]
FIN

POUR R ; retour
MT LC FCC 6 REPETE 180[AV 1 TD 1 ATTENDS 1]
FIN

POUR DEUZ ; deuxième époque ;;'deuz ex machina' ;-)
E CT
REPETE 6 [AV 30 BC REPETE 360[AV 5 RE 5 TD 1 FCC CC + 1] LC RE 30 TD 60]
MT R
TD 72 E CT
REPETE 6 [AV 30 BC REPETE 360[AV 5 RE 5 TD 1 ] AZAR LC RE 30 TD 60]
MT R
TD 72 E CT
REPETE 5 [AV 30 BC REPETE 360[AV 5 RE 5 TD 1 ] AZAR LC RE 30 TD 72]
MT R
TD 72 E CT
REPETE 12 [AV 30 BC REPETE 360[AV 5 RE 5 TD 1 ] AZAR LC RE 30 TD 30]
MT R
TD 72 E CT
REPETE 9 [AV 30 BC REPETE 360[AV 5 RE 5 TD 1 ] AZAR LC RE 30 TD 40]
MT R
FIN

POUR ETOILE
CT LC FPOS [-230 110]
BC FCC 14 REPETE 360[AV 1 + HASARD 30 RE DISTANCE [-230 110] TD 1]
FCC 12 REPETE 360[AV 1 + HASARD 15 RE DISTANCE [-230 110] TD 1]
FIN

POUR B ; bouquet final ;;c'était donc un feu d'artifice ?!...
TD 45 REPETE 120 [AV 2 TD 1 ATTENDS 1]
DONNE "G 1 CT
FCAP 0 BC REPETE 50[REPETE 360[AV :G RE 2 * :G AV :G + .5 TD 1 AZAR ]
DONNE "G :G + 1]
DONNE "G 1 FCC 0
REPETE 50[REPETE 360[AV :G RE 2 * :G AV :G + .5 TD 1 ] DONNE "G :G + 1]
FIN

POUR S ; scénario ;;le programme à lancer pour les débutants n'ayant pas lu les autres pages...
ETOILE D
REPETE 10 [C]
LC ORIGINE E N1 R ATTENDS 4
TD 72 E N2 R ATTENDS 20
TD 72 E N3 R ATTENDS 20
TD 72 E N4 R ATTENDS 20
TD 72 E N5 R
FCAP 0 CT REPETE 20 [C] LC ORIGINE MT
DEUZ FCAP 0 CT REPETE 20 [C] LC ORIGINE MT
FCC 6 B
FIN

Et voici le montage d'une des scènes finales assuré par la Production (le Webmestre, banane !) :


 Quelques explications

 La version de Papy Logo

 Les versions de Baby Logo

 La version de Jean-François L.

La version, avec Terragen, de Laurent Farines

 Une version à six mains

 La version "bijoux" de Loleap